Tooprogram.ru

Компьютерный справочник
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Функция round в excel

Формула Округления ОКРУГЛ() или ROUND() в Excel

Одним из вариантов представления числа до необходимого с заданным количеством знаков разряда является формула Округление ОКРУГЛ() или ROUND() в английском варианте. Она округляет число по стандартным математическим правилам.

Рассмотрим эту формулу, ее вариации и еще приведу пример как можно округлять значения другим способом.

Возьмем абстрактные числа требующие округления:

Начнем писать в строке функций формулу =ОКРУГЛ( и нажмем кнопку Fx:

В окне аргументы функции в поле число указываем адрес ячейки для округления (B2), в поле число_разрядов необходимое число разрядов до которого необходимо округлить (например, 2):

Предварительно Excel уже показывает результат, нажимаем кнопку ОК и протягиваем формулу до конца столбца (до ячейки C5):

Ничего сложного, быстро и удобно.

Формула ОКРУГЛВВЕРХ() или ROUNDUP().

Позволяет произвести округление как и в прошлом примере, но при это вы задает правило округлять последний разряд в большую сторону. Аргументы функции точно такие же, повторяем все предыдущие действия, только формулу теперь пишем ОКРУГЛВВЕРХ(). Результатом будет:

Видно, что последние разряда первого и последнего числа отличаются от предыдущего примера, так как тоже округлились в большую сторону.

Формула ОКРУГЛВНИЗ() или ROUNDDOWN()

Как в предыдущем примере, только округление последнего разряда будет в меньшую сторону. По идеи в нашем примере от функции ОКРУГЛ() должны отличаться цифры №2 и 3. Проверим:

Формула ОКРГУЛТ() или MROUND()

Но есть еще одна функция округления это функция ОКРУГЛТ() или MROUND(). Она позволяет найти ближайшее большее число кратное точности. Для простоты упростим наш пример:

В строке функций начинаем набирать формулу =ОКРУГЛТ() и нажимаем Fx. В окне аргументов вводим число и укажем точность равной 3, получаем результат:

Для первого числа ответ 9. Это ближайшее большее число кратное цифре 3.

Округление с помощью форматов.

Заменить функцию округления (в стандартном ее исполнении) можно задав формат числа. Для нашего примера выделяем ячейки:

Нажимаем ПКМ – формат ячеек.

В числовых форматах выбираем числовой:

Указываем число десятичных знаков, мы округляли до 3 знаков, укажем так и здесь:

Нажимаем ОК. Наблюдаем результат:

На этом с округлением значений все. Пишите в комментариях пожелания и вопросы.

Примеры функций ОКРГУЛ и ОКРУГЛТ для округления чисел в Excel

Функция ОКРУГЛ используется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение. Например, для округления числа 1,22365 до двух знаков после запятой можно ввести формулу =ОКРУГЛ(1,22365;2), которая вернет значение 1,22.

Функция ОКРУГЛТ используется для округления чисел с требуемой точностью и возвращает округленное значение. Функция ОКРУГЛТ принимает во внимание значение, являющееся остатком от деления округляемого числа на указанную точность. Операция округления будет произведена только в том случае, если оно равно или больше ½ точности.

Примеры использования функций ОКРУГЛ и ОКРУГЛТ в Excel

Пример 1. Стоимость валюты составляет 70 рублей. Определить наибольшее количество валюты, которое можно приобрести, если покупатель взял с собой 2200 рублей. Как известно, в обменных пунктах выдают только купюры.

Для решения используем следующую формулу:

Функция ОКРУГЛ принимает следующие параметры:

  • B3/B2 – частное от деления суммы имеющихся рублей на стоимость одной валюты;
  • 0 – значение, указывающее на то, что округление будет выполняться до целого числа.
Читать еще:  Как записать градусы в excel

Если произведение округленного значения и курса валюты превышает сумму имеющихся рублей, то из первого будет вычтена единица, иначе будет возвращено просто округленное значение.

То есть, 2200 рублей можно поменять не более чем на 31 у.е.

Как перевести мили в километры используя функцию ОКРУГЛ в Excel

Пример 2. Спидометр автомобиля отображает скорость в единицах измерения мили/ч. 1 миля = 1609 м (1,609 км). Определить скорость автомобиля в километрах часов (округленно до одного знака после запятой), если на данный момент спидометр показывает скорость 75 миль/ч.

Формула для решения:

  • B3*B2 – перевод миль/ч в км/ч;
  • 1 – количество знаков после запятой для округления.

Калькулятор расчета мощности кондиционера по площади комнаты в Excel

Пример 3. Для помещения площадью 60 кв. м и высотой потолка 2,7 м необходимо подобрать кондиционер по мощности. Поставщики предлагают кондиционеры мощностью от 2 кВт с шагом 0,5 кВт. Определить подходящий кондиционер.

Искомая мощность рассчитывается как произведение площади, высоты потолка и коэффициента q. Используем следующую формулу:

Для автоматического выбора кондиционера используем формулу:

В данном случае функция ЕСЛИ выполняет проверку дробной части найденного значения мощности на принадлежность к промежутку значений от 0 до 0,25 и от 0,5 до 0,75. Это необходимо для правильного выбора кондиционера по мощности. Например, если бы результатом расчетов являлась мощность 5,2 кВт, функция ОКРУГЛТ(5,2;0,5) вернула бы значение 5. Однако мощность выбранного кондиционера должна быть равной или больше расчетной. Поэтому в этом случае к результату будет добавлено значение 0,5.

Результат расчета мощности кондиционера по площади комнаты:

Особенности использования функций ОКРУГЛ и ОКРУГЛТ в Excel

Обе функции используются для округления числовых значений наряду с прочими функциями ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ. Функция ОКРУГЛ имеет следующую синтаксическую запись:

  • число – обязательный аргумент, характеризующий числовое значение, для которого требуется выполнение операции округления;
  • число_разрядов – обязательный аргумент, характеризующий количество знаков после запятой в числе после округления.

Функция ОКРУГЛТ имеет следующий синтаксис:

  • число – обязательный аргумент, соответствует одноименному аргументу функции ОКРУГЛ;
  • точность – обязательный аргумент, характеризующий числовое значение точности округления числа.

Как округлить числа в Excel с помощью функции ROUND

Как округлить числа в Excel с помощью функции ROUND

В некоторых случаях следует использовать округление значений до ближайшего десятичного или целого числа, чтобы улучшить внешний вид и четкость презентации Excel. Когда вы округляете числа, вы удаляете наименее значимые цифры. Это приводит к более презентабельным значениям с выбранным вами уровнем точности.

Округление часто используется для получения оценок и упрощения работы с числами. Например, если я хочу рассчитать процентную скидку и получу число, например 17.3587563, округление его до одного знака после запятой даст мне 17,4%, что более презентабельно. В этом уроке хорошо показано, как округлять числа с помощью функции ROUND.

Как округлить числа в Excel с помощью функции ROUND

Функция Excel ROUND

ROUND Функция является самой популярной и наиболее часто используемой функцией Excel для округления чисел. Эта функция округляет числа до ближайшего десятичного знака на основе указанного вами количества цифр. Если следующая цифра справа — 0, 1, 2, 3 или 4, она округляется вниз. Если следующая цифра справа 5, 6, 7, 8 или 9, она округляется. Таким образом, 7,82564, округленное до двух десятичных знаков, станет 7,83. Вот как использовать функцию Excel ROUND.

Читать еще:  Вставить формулу в excel vba

1. Откройте существующую книгу Excel с необработанными числами или создайте новую таблицу. Затем создайте новый столбец рядом со значениями, которые вы хотите округлить или уменьшить, и присвойте ему имя.

2. Нажмите, чтобы выделить ячейку, в которую вы хотите поместить округленное значение.

3.Перейдите к главной ленте и выберите меню «Формулы».

4. В разделе «Формула» выберите и щелкните параметр «Математика и триггеры», как показано ниже.

Откроется раскрывающееся меню «Формулы». Выберите функцию ROUND в опциях меню.

Как округлить числа в Excel с помощью функции ROUND

5. Это откроет окно аргумента функции, где вы сможете настроить функцию на желаемый результат. Введите число, которое вы хотите округлить в поле Число. Самый простой способ сделать это — ввести номер ячейки, на которую вы ссылаетесь. В нашем случае используйте B4, чтобы указать верхнюю ячейку в столбце наших значений.

Введите число цифр, до которого число должно быть округлено, в поле Num_digits. Здесь указывается количество цифр, которое вы хотите получить в результате. Например, вы можете ввести 2, чтобы обозначить два десятичных знака.

Если вы хотите округлить числа до ближайших 10 или 100, вставьте отрицательное число в поле Number. При этом число округляется до правой части десятичной дроби. Например, если вы вставите -1 в числовое поле и округлите число, например 427,13, полученное значение будет 430.

6. Нажмите OK, чтобы число появилось в столбце «Результаты».

7. Теперь вы хотите применить формулу ко всем другим ячейкам. Для этого щелкните в правом нижнем углу и перетащите формулу вниз до остальных ячеек.

Вот и все. Вы только что округлили все числа до желаемого количества цифр.

Использование синтаксиса ROUND

Кроме того, вы можете использовать синтаксис функций, который намного проще по сравнению с описанным выше методом.

Синтаксис функций относится к разбивке формулы функции и включает в себя имя функции, скобки и аргументы. Аргументами являются Number и Num_digits.

Синтаксис для формулы ROUND:

= ROUND (number, num_digits)

, где Number — это значение, которое необходимо округлить, а Num_digits — это число цифры, до которых будет округлено число.

Чтобы использовать формулу синтаксиса ROUND, просто выполните следующие шаги.

1. Выберите ячейку, в которую хотите поместить результаты.

2. Переместите курсор на панель функций и нажмите, чтобы активировать ее.

3. Введите синтаксис для круглой формулы. Вот как это будет выглядеть в нашем случае.

4. Нажмите Enter, и округленное значение появится в столбце результатов. Затем можно перетащить округленное число вниз, чтобы формула применялась к остальным ячейкам.

Обтекание

Округление чисел — отличный способ сделать вашу таблицу Excel аккуратной и презентабельной. А поскольку функция Excel ROUND следует математическим правилам округления чисел, вы получите очень точные результаты, которые лучше отражают реальные цифры.

Читать еще:  Формула чиствндох в excel пример

Канал в Telegram

Вы здесь

Функции округления чисел в Excel

При работе с функциями в Excel, Вы наверно замечали набор функций ОКРУГЛ(), ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() категории «Математические». В чем отличия между этими функциями и как они работают?

Ранее, в статье «Формат данных в Excel», я описывал форматы представления данных в Excel. С помощью представления можно добавить или сократить дробную часть числа, но фактический формат числа остается неизменным. Часто, при делении чисел, дробная часть получается очень длинной, что в дальнейшем может мешать при некоторых расчетах и выдавать результат не тот, который ожидался. Для того чтобы сократить дробную часть числа (округлить), используется функция ОКРУГЛ(), в которой можно указать необходимое число разрядов после запятой. Также возможно округление и целой части.

Округление происходит следующим образом:
-Если число меньше 5, то следующий разряд остается неизменным.
-Если число равно или больше 5, то к следующему разряду добавляется единица.

Например, число 2553,5675643 после округления до сотых будет выглядеть 2553,57
В общем, округление по школьной программе 🙂

Теперь рассмотрим как работает функция ОКРУГЛ() и какие имеет аргументы.

Синтаксис функции прост — ОКРУГЛ(Число; Число разрядов).

  • Число – в этом аргументе указывается ссылка на ячейку с числом, которое необходимо округлить или вводите значение. Допускает использование других функции, результатом которых является число.
  • Число разрядов — значение этого аргумента указывает, до какого разряда необходимо округлить число. При указании в этом аргументе положительного числа, округление будет происходить после запятой. При нуле, округление до целой части. При указании отрицательного аргумента, округляется целая часть. При этом, кол-во разрядов в целой части, сохраняется и заполняется нулями.

Пример:
Округлим число 2553,5675643
Запись функции следующая:

«=ОКРУГЛ(2553,5675643;2)» вернет результат 2553,57
«=ОКРУГЛ(2553,5675643;0)» вернет 2554
«=ОКРУГЛ(2553,5675643;-2)» вернет 2600

В Excel так же есть функции ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ(). Все эти функции практически аналогичны работе с функцией ОКРУГЛ(), но у каждой из них немного иной алгоритм округления.

Функция:
ОКРВВЕРХ() — функция округляет число до ближайшего целого, которое кратно числу, указанного в аргументе «точность«. Округление происходит в большую сторону.

Примеры:
«=ОКРВВЕРХ(2553,57;1)», результат 2554
«=ОКРВВЕРХ(2553,57;3)», вернет результат кратный 3 т.е. 2556

Для округления отрицательных чисел, аргумент «точность» должен быть также отрицательным, иначе функция вернет ошибку «#ЧИСЛО!«
«=ОКРВВЕРХ(-2553,57;-2)», результат -2554

И еще один пример округления, но уже дробного числа
«=ОКРВВЕРХ(0,578;0,02)» результат 0,58

ОКРВНИЗ() функция аналогична ОКРВВЕРХ(), с той лишь разницей что округление происходит в меньшую сторону.
«=ОКРВНИЗ(2553,57;2)» результат 2552

ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() — функции по принципу работы схожи с функцией ОКРУГЛ(). Отличие в том, что эти функции округляют число с избытком(недостатком).

Примеры:
«=ОКРУГЛВВЕРХ(2553,34;1)», результат получится 2553,4
«=ОКРУГЛВВЕРХ(2553,34;-1)», результат 2560
«=ОКРУГЛВНИЗ(2553,34;1)», результат 2553,3
«=ОКРУГЛВНИЗ(2553,34;-1)», результат 2550

Ссылка на основную публикацию
Adblock
detector