Tooprogram.ru

Компьютерный справочник
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Подсчет количества строк в excel

Подсчет числа строк в Microsoft Excel

При работе в Excel иногда нужно подсчитать количество строк определенного диапазона. Сделать это можно несколькими способами. Разберем алгоритм выполнения этой процедуры, используя различные варианты.

Определение количества строк

Существует довольно большое количество способов определения количества строк. При их использовании применяются различные инструменты. Поэтому нужно смотреть конкретный случай, чтобы выбрать более подходящий вариант.

Способ 1: указатель в строке состояния

Самый простой способ решить поставленную задачу в выделенном диапазоне – это посмотреть количество в строке состояния. Для этого просто выделяем нужный диапазон. При этом важно учесть, что система считает каждую ячейку с данными за отдельную единицу. Поэтому, чтобы не произошло двойного подсчета, так как нам нужно узнать количество именно строк, выделяем только один столбец в исследуемой области. В строке состояния после слова «Количество» слева от кнопок переключения режимов отображения появится указание фактического количества заполненных элементов в выделенном диапазоне.

Правда, случается и такое, когда в таблице нет полностью заполненных столбцов, при этом в каждой строке имеются значения. В этом случае, если мы выделим только один столбец, то те элементы, у которых именно в той колонке нет значений, не попадут в расчет. Поэтому сразу выделяем полностью конкретный столбец, а затем, зажав кнопку Ctrl кликаем по заполненным ячейкам, в тех строчках, которые оказались пустыми в выделенной колонке. При этом выделяем не более одной ячейки на строку. Таким образом, в строке состояния будет отображено количество всех строчек в выделенном диапазоне, в которых хотя бы одна ячейка заполнена.

Но бывают и ситуации, когда вы выделяете заполненные ячейки в строках, а отображение количества на панели состояния так и не появляется. Это означает, что данная функция просто отключена. Для её включения кликаем правой кнопкой мыши по панели состояния и в появившемся меню устанавливаем галочку напротив значения «Количество». Теперь численность выделенных строк будет отображаться.

Способ 2: использование функции

Но, вышеуказанный способ не позволяет зафиксировать результаты подсчета в конкретной области на листе. К тому же, он предоставляет возможность посчитать только те строки, в которых присутствуют значения, а в некоторых случаях нужно произвести подсчет всех элементов в совокупности, включая и пустые. В этом случае на помощь придет функция ЧСТРОК. Её синтаксис выглядит следующим образом:

Её можно вбить в любую пустую ячейку на листе, а в качестве аргумента «Массив» подставить координаты диапазона, в котором нужно произвести подсчет.

Для вывода результата на экран достаточно будет нажать кнопку Enter.

Причем подсчитываться будут даже полностью пустые строки диапазона. Стоит заметить, что в отличие от предыдущего способа, если вы выделите область, включающую несколько столбцов, то оператор будет считать исключительно строчки.

Пользователям, у которых небольшой опыт работы с формулами в Экселе, проще работать с данным оператором через Мастер функций.

    Выделяем ячейку, в которую будет производиться вывод готового итога подсчета элементов. Жмем на кнопку «Вставить функцию». Она размещена сразу слева от строки формул.

Запускается небольшое окно Мастера функций. В поле «Категории» устанавливаем позицию «Ссылки и массивы» или «Полный алфавитный перечень». Ищем значение «ЧСТРОК», выделяем его и жмем на кнопку «OK».

Открывается окно аргументов функции. Ставим курсор в поле «Массив». Выделяем на листе тот диапазон, количество строк в котором нужно подсчитать. После того, как координаты этой области отобразились в поле окна аргументов, жмем на кнопку «OK».

  • Программа обрабатывает данные и выводит результат подсчета строк в предварительно указанную ячейку. Теперь этот итог будет отображаться в данной области постоянно, если вы не решите удалить его вручную.
  • Способ 3: применение фильтра и условного форматирования

    Но бывают случаи, когда нужно подсчитать не все строки диапазона, а только те, которые отвечают определенному заданному условию. В этом случае на помощь придет условное форматирование и последующая фильтрация

      Выделяем диапазон, по которому будет производиться проверка на выполнение условия.

    Переходим во вкладку «Главная». На ленте в блоке инструментов «Стили» жмем на кнопку «Условное форматирование». Выбираем пункт «Правила выделения ячеек». Далее открывается пункт различных правил. Для нашего примера мы выбираем пункт «Больше…», хотя для других случаев выбор может быть остановлен и на иной позиции.

    Открывается окно, в котором задается условие. В левом поле укажем число, ячейки, включающие в себя значение больше которого, окрасятся определенным цветом. В правом поле существует возможность этот цвет выбрать, но можно и оставить его по умолчанию. После того, как установка условия завершена, жмем на кнопку «OK».

    Как видим, после этих действий ячейки, удовлетворяющие условию, были залиты выбранным цветом. Выделяем весь диапазон значений. Находясь во все в той же вкладке «Главная», кликаем по кнопке «Сортировка и фильтр» в группе инструментов «Редактирование». В появившемся списке выбираем пункт «Фильтр».

    После этого в заглавиях столбцов появляется значок фильтра. Кликаем по нему в том столбце, где было проведено форматирование. В открывшемся меню выбираем пункт «Фильтр по цвету». Далее кликаем по тому цвету, которым залиты отформатированные ячейки, удовлетворяющие условию.

  • Как видим, не отмеченные цветом ячейки после данных действий были спрятаны. Просто выделяем оставшийся диапазон ячеек и смотрим на показатель «Количество» в строке состояния, как и при решении проблемы первым способом. Именно это число и будет указывать на численность строк, которые удовлетворяют конкретному условию.
  • Как видим, существует несколько способов узнать количество строчек в выделенном фрагменте. Каждый из этих способов уместно применять для определенных целей. Например, если нужно зафиксировать результат, то в этом случае подойдет вариант с функцией, а если задача стоит подсчитать строки, отвечающие определенному условию, то тут на помощь придет условное форматирование с последующей фильтрацией.

    Читать еще:  Hex в excel

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Определение количества строк Экселе

    В процессе работы с таблицами Эксель достаточно часто возникает необходимость в определении количества строк. Для этого существует несколько основных методов, причем выбор и использование конкретного определяется условиями стоящей перед пользователем задачи. В данной статье описано несколько основных способов определения количества строк в таблице Эксель в зависимости от ее структуры и наполненности, а также конкретной ситуации.

    Метод 1: информация в строке состояния

    Проще всего посмотреть количество строк в строке состояния Эксель, расположенной внизу его основной рабочей области. Порядок действий описан ниже:

    1. Сначала, удерживая левую кнопку мыши, выделяем диапазон ячеек, для которого надо подсчитать количество строк. Эксель по умолчанию считает все ячейки, в которые занесены данные, поэтому выделяем только один столбец. В противном случае данные по количеству строк будут некорректны.
    2. В нижней части окна находим строку состояния программы, в которой после слова “Количество” отображается число ячеек, заполненных данными. Это и есть количество строк, которое мы хотели найти.

    Примечание: Если выделенный столбец таблицы заполнен не полностью, а в других столбцах напротив пропусков присутствуют данные, то мы не сможем посчитать фактическое количество заполненных строк при помощи вышеописанного способа. Поэтому в подобной ситуации будем следовать приведенному ниже алгоритму:

    1. Как и в предыдущем способе, сначала, удерживая левую кнопку мыши, выделяем диапазон, для которого необходимо подсчитать количество строк (строго в пределах одного столбца).
    2. Чтобы дополнительно выделить отдельные ячейки в других столбцах, зажав клавишу Ctrl на клавиатуре при помощи левой кнопки мыши выделяем все заполненные данными ячейки, которые хотим учесть в подсчете количества. Ctrl не отпускаем до конца выделения.
    3. В строке состояния Эксель смотрим получившееся количество. Оно, как мы уже знаем, отображает все ячейки, в которых присутствуют данные. Примечание: нельзя выделять две и более заполненные ячейки из разных столбцов, но при этом принадлежащие одной и той же строке, иначе количество строк будет посчитано неверно.

    Если в строке состояния отсутствует слово “Количество”, проверяем настройки отображения информации для нее.

    1. Для вызова настроек строки состояния нажимаем правую кнопку мыши, наведя курсор на любое место строки состояния внизу окна.
    2. В появившемся окне с настройками строки состояния проверяем наличие галочки напротив пункта Количество. Если флажка нет, устанавливаем его, кликнув левой кнопкой мыши.
    3. Выделяем любой диапазон ячеек и проверяем отображение количества в строке состояния. Теперь нужная информация должна отображаться в строке состояния.

    Метод 2: применение функции ЧСТРОК

    Если первый метод позволяет оперативно посмотреть количество строк путем подсчета заполненных ячеек, то описываемый в этом разделе способ поможет зафиксировать результаты подсчета в виде конкретного значения в свободной ячейке листа. Причем в результат будут включаться все строки – и пустые и с введенными данными. Речь идет о встроенной функции ЧСТРОК, которая позволит реализовать эту задачу.

    Функция ЧСТРОК имеет следующий синтаксис: =ЧСТРОК(массив).

    Давайте на практическом примере разберем, как работает данная функция, воспользовавшись Мастером функций:

    1. Кликаем левой кнопки мыши по любой пустой ячейке (или переходим в нее с помощью навигационных клавиш на клавиатуре), в которой будет выводиться результат работы функции.
    2. Нажимаем кнопку “Вставить функцию” (fx), которая расположена левее строки формул.
    3. Перед нами окно выбора формул Мастера функций. В качестве Категории устанавливаем значение “Полный алфавитный перечень”. В перечне функций ищем оператор “ЧСТРОК”, кликаем по нему, затем жмемОК.
    4. В появившемся окне аргументов функции заполняем значение для поля “Массив”. Для этого выделяем требуемый диапазон ячеек, удерживая левую кнопку мыши (предварительно щелкнув по полю для ввода информации). Также координаты диапазона можно ввести вручную при помощи клавиатуры. По готовности жмем ОК.
    5. Функция выполнит подсчет количества строк и отобразит результат в ячейке с формулой. Причем этот результат будет автоматически пересчитываться при любых изменениях данных в ячейках, включенных в массив функции “ЧСТРОК” до тех пор, пока функция не будет удалена из ячейки.

    Особенностью этого метода является то, что с его помощью считаются все строки – и с данными в ячейках, и без них. Также если в выделенном диапазоне будет присутствовать несколько столбцов, это не повлияет на конечный результат работы функции “ЧСТРОК”.

    Метод 3: условное форматирование и использование фильтра

    Третий метод раскрывает алгоритм действий в ситуации, когда нужно посчитать количество строк для диапазона ячеек с определенными значениями данных в них. Это означает, что в итог расчета попадут только те строки, ячейки которых сгруппированы по конкретному условию или признаку. Речь пойдет об условном форматировании и использовании фильтра.

    1. Выделяем диапазон ячеек, данные которых станут критерием выбора строк.
    2. Во вкладке “Главная” находим раздел “Стили”, среди инструментов находим и кликаем по кнопке “Условное форматирование”.
    3. В появившемся перечне раскрываем пункт “Правила выделения ячеек”, который содержит список правил, определяющих условия форматирования. В нашем примере выделенный диапазон заполнен текстовыми данными, соответственно – выбираем строку “Текст содержит…”.
    4. Далее задаем конкретные условия форматирования – для каких значений ячеек они будут окрашиваться в определенный цвет. В левой части окна указываем букву A, а в правой части оставляем установку по умолчанию (при желании – выбираем другую цветовую схему). Наша цель – чтобы все ячейки с буквой А подкрашивались в красных тонах. Нажимаем ОК.
    5. Если ячейки с буквой А выделены цветом, значит настройки условного форматирования сделаны корректно.
    6. Чтобы посчитать, сколько строк содержат “подкрашенные” ячейки, используем инструмент “Фильтр”.
    7. Если выделение снято, опять выделяем требуемый диапазон ячеек. Во вкладке “Главная”, находим инструмент “Фильтр” (значок в виде воронки, группа инструментов “Редактирование”) и кликаем по нему.
    8. На верхней ячейке выделенного столбца появится значок пока что неактивного фильтра в виде кнопки со стрелкой вниз:
      • кликаем на него;
      • ищем строку “Фильтр по цвету”, щелкаем по этому пункту;
      • выбираем цвет, использованный для условного форматирования ранее.
    9. В результате работы фильтра в таблице останутся только строки с окрашенными ячейками в выбранном столбце. Теперь можно просто выделить их, чтобы определить итоговое количество в строке состояния. Это и есть количество строк, которое мы хотели выяснить согласно поставленной задаче.
    Читать еще:  Log в excel

    Заключение

    Итак, мы рассмотрели основные методы, позволяющие посчитать количество строк в различных ситуациях. Первый метод позволит быстро оценить количество строк, когда нет необходимости его фиксировать. Второй – позволяет зафиксировать результат в отдельной ячейке. Третий метод сложнее первых двух, но в случае необходимости позволит посчитать количество строк, отобранных по определенному признаку. Кроме того, условное форматирование позволяет визуализировать конкретные условия выбора, “подсветив” их определенным цветом.

    Как выполнить подсчёт ячеек со значением

    Здравствуйте, дорогие читатели.

    Перед началом данной темы я бы хотел вам посоветовать отличный обучающий продукт по теме экселя, по названием « Неизвестный Excel » , там всё качественно и понятно изложено. Рекомендую.

    Ну а теперь вернёмся к теме.

    Вы наверняка являетесь представителем одной из профессий, в которой не обойтись без программы эксель. Ведь она позволяет вести подсчеты, составлять списки, таблицы и диаграммы, заполнять ежедневники и решать многие другие задачи, связанные с цифрами.

    Однако не все, кто работает с этим приложением, знает его полную функциональность и умеет ее применять на практике. Вы один из них? Тогда вы обратились по адресу. В частности, сегодня мы разберем, как в excel подсчитать количество ячеек со значением. Есть несколько способов, как это сделать. Они зависят от того, какое именно содержимое вам нужно посчитать. Разберем самые популярные из них.

    Самый быстрый способ

    Наиболее простым, но в то же время поверхностным, является способ подсчета элементов в строке состояния. Их численность выводится в самой нижней панели открытого окна.

    Если вы хотите задать определенные несложные параметры подсчетам, откройте настройки строки состояния. Это можно сделать, щелкнув правой кнопкой мыши по ней. В появившемся окне обратите внимание на ту часть, где написано «Среднее», «Количество», «Количество чисел», «Минимум», «Максимум» и «Сумма».

    Выберите нужный параметр и узнайте больше о том, что содержит ваша таблица.

    Подсчет ячеек в строках и столбцах

    Существует два способа, позволяющие узнать количество секций. Первый — дает возможность посчитать их по строкам в выделенном диапазоне. Для этого необходимо ввести формулу =ЧСТРОК(массив) в соответствующее поле. В данном случае будут подсчитаны все клетки, а не только те, в которых содержатся цифры или текст.

    Второй вариант — =ЧИСЛСТОЛБ(массив) — работает по аналогии с предыдущей, но считает сумму секций в столбце.

    Считаем числа и значения

    Я расскажу вам о трех полезных вещах, помогающих в работе с программой.

    1. Сколько чисел находится в массиве, можно рассчитать с помощью формулы СЧЁТ(значение1;значение2;…). Она учитывает только те элементы, которые включают в себя цифры.То есть если в некоторых из них будет прописан текст, они будут пропущены, в то время как даты и время берутся во внимание. В данной ситуации не обязательно задавать параметры по порядку: можно написать, к примеру, =СЧЁТ(А1:С3;В4:С7;…).
    2. Другая статистическая функция — СЧЕТЗ — подсчитает вам непустые клетки в диапазоне, то есть те, которые содержат буквы, числа, даты, время и даже логические значения ЛОЖЬ и ИСТИНА.
    3. Обратное действие выполняет формула, показывающая численность незаполненных секций — СЧИТАТЬПУСТОТЫ(массив). Она применяется только к непрерывным выделенным областям.

    Ставим экселю условия

    Когда нужно подсчитать элементы с определённым значением, то есть соответствующие какому-то формату, применяется функция СЧЁТЕСЛИ(массив;критерий). Чтобы вам было понятнее, следует разобраться в терминах.

    Массивом называется диапазон элементов, среди которых ведется учет. Это может быть только прямоугольная непрерывная совокупность смежных клеток. Критерием считается как раз таки то условие, согласно которому выполняется отбор. Если оно содержит текст или цифры со знаками сравнения, мы его берем в кавычки. Когда условие приравнивается просто к числу, кавычки не нужны.

    Разбираемся в критериях

    • «>0» — считаются ячейки с числами от нуля и выше;
    • «Товар» — подсчитываются секции, содержащие это слово;
    • 15 — вы получаете сумму элементов с данной цифрой.

    Для большей ясности приведу развернутый пример.

    Чтобы посчитать ячейки в зоне от А1 до С2, величина которых больше прописанной в А5, в строке формул необходимо написать =СЧЕТЕСЛИ(А1:С2;«>»&А5).

    Задачи на логику

    Хотите задать экселю логические параметры? Воспользуйтесь групповыми символами * и ?. Первый будет обозначать любое количество произвольных символов, а второй — только один.

    К примеру, вам нужно знать, сколько имеет электронная таблица клеток с буквой Т без учета регистра. Задаем комбинацию =СЧЕТЕСЛИ(А1:D6;«Т*»). Другой пример: хотите знать численность ячеек, содержащих только 3 символа (любых) в том же диапазоне. Тогда пишем =СЧЕТЕСЛИ(А1:D6;«. »).

    Читать еще:  Виснет файл excel

    Средние значения и множественные формулы

    В качестве условия может быть задана даже формула. Желаете узнать, сколько у вас секций, содержимое которых превышают среднее в определенном диапазоне? Тогда вам следует записать в строке формул следующую комбинацию =СЧЕТЕСЛИ(А1:Е4;«>»&СРЗНАЧ(А1:Е4)).

    Если вам нужно сосчитать количество заполненных ячеек по двум и более параметрам, воспользуйтесь функцией СЧЕТЕСЛИМН. К примеру, вы ищите секций с данными больше 10, но меньше 70. Вы пишете =СЧЕТЕСЛИМН(А1:Е4;«>10»;А1:Е4;« Этой статьей стоит поделиться

    Как подсчитать количество повторений

    В этой статье я хочу рассказать, как можно подсчитать количество повторений какого-либо значения в таблице или в ячейке. Начнем по порядку. Имеется таблица:

    И необходимо подсчитать количество повторений каждого наименования:

    Как ни странно, но сделать это весьма просто: в Excel имеется функция — СЧЁТЕСЛИ, при помощи которой все это сделать можно буквально за секунды. Если количество повторений каждого наименования необходимо вывести в столбец В таблицы, а сами наименования расположены в столбце А:
    =СЧЁТЕСЛИ( $A$2:$A$30 ; A2 )
    Диапазон ( $A$2:$A$30 ) — указываются ячейки диапазона, в которых записаны значения, количество которых необходимо подсчитать. Главная особенность: данный аргумент может быть исключительно ссылкой на ячейку или диапазон ячеек. Недопустимо указывать произвольный массив значений.
    Критерий ( A2 ) — указывается ссылка на ячейку или непосредственно значение для подсчета. Т.е. можно указать и так: =СЧЁТЕСЛИ( $A$2:$A$30 ;»Яблоко») . Помимо этого можно применять символы подстановки: ? и *. Т.е. указав в качестве Критерия «*банан*» можно подсчитать количество ячеек, в которых встречается слово «банан» (банановый, банан, бананы, банановый сок, сто бананов, три банана и орех и т.п.). А указав «банан*» — значения, начинающиеся на «банан» (бананы, банановый сок, банановая роща и т.п.). «?» — заменяет лишь один символ, т.е. указав «бан?н» можно подсчитать строки и со значением «банан» и со значением «банон» и т.д. Если в качестве критерия указать =СЧЁТЕСЛИ( $A$2:$A$30 ;»*») , то будут подсчитаны все текстовые значения. Числовые значения при этом игнорируются. Данные подстановочные символы (* и ?) не получится применить к числовым значениям — исключительно к тексту. Т.е. если если указать в качестве критерия «12*», то числа 1234, 123, 120 и т.п. не будут подсчитаны. Для подсчета числовых значений следует применять операторы сравнения: =СЧЁТЕСЛИ( $A$2:$A$30 ;»>12″)

    Подсчитать числа, которые больше нуля: =СЧЁТЕСЛИ( $A$2:$A$30 ;»>0″)
    Подсчитать количество непустых ячеек: =СЧЁТЕСЛИ( $A$2:$A$30 ;»<>«)

    Как видно из второго рисунка — там наименования не повторяются, хотя в таблице они все записаны вперемешку. Я не буду заострять на этом внимание — я уже описывал это в статье Как получить список уникальных(не повторяющихся) значений? и при необходимости можно воспользоваться любым описанным в ней методом.

    Но. Бывают случаи, когда список расположен вовсе не в таблице, а в одной ячейке( $D$1 ):
    Дыня Киви Груша Яблоко Дыня Груша Груша Арбуз Яблоко Банан Яблоко Яблоко Банан Яблоко Яблоко Дыня Дыня Киви Банан Дыня Арбуз Дыня Киви Яблоко Дыня Груша Яблоко Киви Арбуз
    Здесь СЧЁТЕСЛИ точно не поможет. Но в Excel полно других функций и все можно сделать так же достаточно просто:
    =(ДЛСТР( $D$1 )-ДЛСТР(ПОДСТАВИТЬ( $D$1 ; D3 ;»»)))/ДЛСТР( D3 )
    ДЛСТР — подсчитывает количество символов в указанной ячейке/строке( $D$1 , D3 )
    ПОДСТАВИТЬ (текст; старый_текст; новый_текст) — заменяет в указанном тексте заданный символ на любое другое заданное значение. По умолчанию заменяет все повторы указанного символа. Именно это и положено в основу алгоритма. На примере значения Банан( D3 ) пошаговый разбор формулы:

    • при помощи функции ДЛСТР получаем количество символов в строке с исходным текстом( $D$1 ) =(170-ДЛСТР(ПОДСТАВИТЬ( $D$1 ; D3 ;»»)))/ДЛСТР( D3 ) ;
    • при помощи функции ПОДСТАВИТЬ заменяем в строке с исходным текстом( $D$1 ) все значения Банан( D3 ) на пусто и при помощи ДЛСТР получаем количество символов строки после этой замены =(170-155)/ДЛСТР( D3 ) ;
    • вычитаем из общего количества символов количество символов в строке после замены и делим результат на количество символов в критерии =(170-155)/5 .

    Получаем число 3. Что нам и требовалось.

    И простая функция пользователя, которая так же подсчитывает повторения внутри ячейки:

    Function GetRepeat(sTxt As String, sCntWord As String) GetRepeat = (Len(sTxt) — Len(Replace(sTxt, sCntWord, «»))) / Len(sCntWord) End Function

    Чтобы правильно использовать приведенный код, необходимо сначала ознакомиться со статьей Что такое функция пользователя(UDF)?. Вкратце: скопировать текст кода выше, перейти в редактор VBA( Alt + F11 ) -создать стандартный модуль(InsertModule) и в него вставить скопированный текст. После чего функцию можно будет вызвать из Диспетчера функций( Ctrl + F3 ), отыскав её в категории Определенные пользователем (User Defined Functions) .
    Синтаксис функции:
    =GetRepeat( $D$1 ; D3 )
    sTxt — текст, в котором подсчитываем кол-во вхождения.
    sCntWord — текст для подсчета. Может быть символом или словом.

    Tips_All_Count_Duplicate.xls (39,0 KiB, 9 457 скачиваний)

    Статья помогла? Поделись ссылкой с друзьями!

    Поиск по меткам

    Добрый день.
    Можете ли вы мне помочь?

    Нужно посчитать количество повторений по столбцу рейс только в одной строке.
    Рейс. Объем. Колич
    повтор
    1аб. 2 2
    1ав. 3. 1
    1 аб. 0.3. 2 (2нужно посчитать как 0)
    2аг. 9. 2
    2аг. 3. 2 (2нужно посчитать как 0)
    2ав. 0.4. 1

    Убрать дубликаты не могу, т.к удаляет всю строку, а значения в поле объем нужны для дальнейшего расчета. Упорядочить значения в столбце рейс тоже нельзя, т.к во всей исходной таблице есть объединенные ячейки, которые нельзя разбить.

    Попробуйте задать вопрос в форуме , приложив пример файла с данными. По одному описанию у меня не получается понять задачу.

    Ссылка на основную публикацию
    Adblock
    detector